GHOST: una nuova falla affligge i sistemi Linux



A distanza di qualche mese dalla scoperta di Poodle, una nuova vulnerabilità si aggira sui sistemi Linux, il suo nome è GHOST.
Il nome deriva da come questa falla viene sfruttata, ossia tramite la funzione GetHOST che viene utilizzata dalle chiamate di funzione gethostbyname.

Per sfruttare la falla secondo i ricercatori di qualys è sufficiente inviare una email composta in modo particolare verso un server Linux vulnerabile, il quale verrà definitivamente compromesso con l’apertura di una shell operabile da remoto.
Non viene fatta nessuna eccezione tra sistemi a 32 o 64-bit, e nessun meccanismo di sicurezza avanzato (ASLR, PIE, NX) a disposizione degli OS e dei processori moderni esclude qualche sistema.

Per fixare la vulnerabilità le principali aziende stanno distribuendo le patch necessarie per le seguenti distribuzioni:

  • RHEL (Red Hat Enterprise Linux) version 5.x, 6.x and 7.x
  • CentOS Linux version 5.x, 6.x & 7.x
  • Ubuntu Linux version 10.04, 12.04 LTS
  • Debian Linux version 7.x
  • Linux Mint version 13.0
  • Fedora Linux version 19 or older
  • SUSE Linux Enterprise 11 and older (also OpenSuse Linux 11 or older versions).
  • SUSE Linux Enterprise Software Development Kit 11 SP3
  • SUSE Linux Enterprise Server 11 SP3 for VMware
  • SUSE Linux Enterprise Server 11 SP3
  • SUSE Linux Enterprise Server 11 SP2 LTSS
  • SUSE Linux Enterprise Server 11 SP1 LTSS
  • SUSE Linux Enterprise Server 10 SP4 LTSS
  • SUSE Linux Enterprise Desktop 11 SP3
  • Arch Linux glibc version <= 2.18-1

E ‘interessante notare, tuttavia, che Ubuntu 14.04 LTS che è uscito nel mese di aprile 2014 (prima di Red Hat Enterprise Linux 7) non risulta vulnerabile a GHOST.

Per fixare la vulnerabilità segnalo questo interessante link dove viene spiegato per le principali distribuzioni quali sono le istruzioni da eseguire.

Non rimane che aggiornare al più presto ogni sistema afflitto dalla vulnerabilità.

Tags: ,